Edmunds Answers

Answers

  • repriebe 10/26/10 12:37 am PST

    Did you find a resolution to your problem? I am working on a 2000 Astro that started doing the same thing yours is doing, only every once in a while at first, but then started doing different and odd things as time progressed. Now the Instrument Cluster will work fine sometimes, then the Speedometer, Gear Indicator, Fuel Gauge, Temperature Gauge, and all the warning lights (except the Turn Signal Indicators and the Service Engine Soon Light) will stop working. Sometimes this will last for a short while, sometimes for long times. Sometimes, all of a sudden, it will come back to life and flash all the warning lamps (like you just turned on the key) while driving down the road, then work perfectly before quitting again at random. I have found that at the times it is not working the miles do not advance, but while it is working the miles advance as normal. I have checked all grounds, fuses, and even replaced the BCM (with a used one from a junkyard) all to no avail. Everything else electrical on the van works perfectly. I have a full wiring diagram and am continuing to diagnose it and will let you know more what I find. Let me know if you are still experiencing problems with yours or if you have any resolutions. THANKS! Rodney

  • contractor5 10/27/11 3:49 pm PST

    I had the same problem on my 2000 Astro.


    Under the driver side knee bolster there is a harness with shunt ( cap) and 8 wires of different colors of blue green yellow, white with blue and so on.
    make sure that cap did not came lose ( The cap does the bridging where needed).
    Just putting that cap back solved my problem.

    Instrument cluster is another place I would look for the proble if the first one doesn't help, but before geting to Instrument cluster you need to disable the airbags. Stay away from Yellow thicker wires they are for airbag..

    Now, there is one thing...
    Do you have an access to a OBDii scanner? Preferabley with ABS capability.
    OR is there an auto parts store in your area that offers free scanning?
    Let us know how it went.
    Good luck


  • gizmobuff 07/05/12 10:17 pm PST

    I have been experiencing this problem for some time. It stated as a simple gas guage problem. Now, the gas guage and temperature guage do not work. Like you, I also have the low fuel and battery lights on, as well as the gear selector light not working. My van also runs well.

    I looked for the eight position connector and cap under the knee bolster and could not find it. In addition, I checked all of the cables under the dash, but could not correct the problem. Tomorrow I will try pulling the guage cluster.

    Did you find an answer to your problem? Anything that you or anyone else could add would be appreciated.

    Thanks.....

  • stirs 10/17/13 8:06 pm PST

    For what it's worth I found a corroded wire in the bundle of red wires going to the bottom of the hood fuse box. The sharp plastic cut the wire and over time it turned green at the cut and opened the copper. This caused the dash to go crazy. Spliced the wire and all was OK. After reading people replacing computers etc and hundreds of dollars with no results I know I was lucky to find the problem and want to pass it on.

  • Stever@Edmunds 10/17/13 8:55 pm PST

    Thanks Stirs!

  • morleo 03/12/14 2:18 pm PST

    My 2003 Astro was doing the same thing for 5 months. My problem and yours may be different, the connectors to the Electronic Control Module (ECM) (Computer), next to the battery, had taken on water. 8 of the pins on the blue side had severe green copper oxidation. The holes were charred and had black gunk in them.

    I used my smallest jeweler's screwdriver to clean out the holes and a very small flat file to clean the pins. I also blew out all the residual water.

    My problem is finally resolved. Good Luck.

    Oh yeah... Before reassembly, seat the gaskets back in the connectors and reconnect them before you put the ECM back in place.

    Disconnecting the positive side of the battery not only protects the circuitry, but it gives you an easy path to remove the ECM.

  • gsurace 04/10/14 10:19 pm PST

    I
    realize this is an old post but I have the same issue...temp and fuel gauge not
    working, low fuel and battery light are on and gear selector light does not
    work either.






    I was on another forum
    and I found the same issue and believe it or not, the solution they had was a
    corroded SRS module under the driver’s seat. I had to cut the floor mat (rather
    than take the seat out) to get to it and when I did, same issue. It was full of
    corrosion. I unplugged the cable harness going to it and all the gauges and
    lights went right back to normal.






    Yes, I found it to be
    strange that the module that controls the airbags made the gauges go wacky but
    it worked for me as well as the others on that forum. Of course I will replace
    it as the airbags are now disabled...I think.

ADVERTISEMENT

Top Electrical Instrument Panel Experts View More

Rank Leader Points
1. karjunkie 910
2. MrShift@Edmunds 655
3. docj 455
4. zaken1 450
5. tony78 295
6. Stever@Edmunds 225
7. 0patience 185
ADVERTISEMENT