Edmunds Answers



  • karjunkie 07/23/09 4:40 pm PST

    Hey Bill. I would assume the simplest explanation first. You have a bad fuel pump. Why? Well, it was already making you wait 10 minutes to produce enough pressure to start right? Passkey can be a hellish system but you had no problem with it before so I'd conclude the fuel pump is the culprit. It just stands to reason that that is the problem. As to spark, you don't need any fancy tester. Just pull a plug and hold it with insulated pliers up against the engine block and see if it sparks. My bet is that you'll find that the plugs are bone dry and that the problem is the fuel system. Now one thing to check is the fuel pressure regulator because those tend to go bad after so many years. Pull the vacuum hose and see if there's any fuel in the hose after cranking the engine. If so, the FPR diaphragm is ruptured and thats where the problem is. But I still would bet the fuel pump is the problem! Good luck!

  • billw67 07/24/09 11:32 am PST

    Well it's been giving me fits like this for awhile now.And typical for the passkey system if you wait about 10 min it all clears.Not takeing 10 min to achieve pressure.Have had noother performance issues other than what seem to be typical passkey fits.However this time it's not clearing.The passkey sys will prevent the fuel pump from working thereby keepingthe vehicle from running.Plan to shoot some gas down the intake and see if she fires.Also plan to pull the pump and bench test it.Will do the test with a fuel pressure gage inline since cant do it in vehicle.(pump non-engageing).Also plan to check the connections to the pump while its out see if theres power going to the pump even.Could be as simple as a broken wire.Wondering if can add a bypass to the pump relay off an ignition on source that would kick the pump in.Hmmmnnnn have to check out the schmeatics for that possiability.
    Thanx and please keep the thoughts comeing......Bill

  • karjunkie 07/24/09 1:24 pm PST

    OK, then the next step to guarantee its the passkey system is to test the fuel pump fuse and see if you have 12V there when you first turn the key on. If you don't it is the passkey and you do not need to pull the pump and test it.

  • billw67 08/08/09 10:35 am PST

    Have checked the wireing diagram in haynes didnt see a fuse and checked the relay as well as changed relay under the hoos so it's fine and has power at relay but won't trigger.so powers not leaveing relay to run pump.Thereby giving me the impression it's the passkey system.Just installed new ignition switch assembly.Still no start.Have not transfered the aftermarket device that i would assume is a remote start from old switch assembly to new assembly.What i did was drop the old assy and hooked up and installed the new assy.the old assy is still under the column with whatever the aftermarket devise is attached to it.Wish i could getthe name of the aftermarket thing.All stickers have been removed and the boards have no names on them.At least none that have turned up anything on online searchs.Realy hate to justtransfer the item to the new switch not knowing exactly what it dose because it could be part of the problem.

  • billw67 08/08/09 10:52 am PST

    todays plan is to physically drop the gas tankand test the wires for power as well as test the pump itself.Just being anal and hopeing to eliminate the pumpitself as the issue.

  • gimpyredneck 08/09/09 11:10 am PST

    Hi, Names Andrew, I also have the same problems with my 2001 Chevy S-10 Blazer, no remote starter, just a key.. had me stumped for a long time.. but in my case i figured out a "FREE" solution.. Im not saying that this will fix your problem, but while I would sit there for ten minutes waiting, I fiddle with crap.. My mechanic friend told me about the dredded "Passkey" crap.. and I got to thinking, its a security thing, correct? could it be as simple as "Jiggling" the driver side door switch? or even replacing it.. if you think about it.. once the switch has a crap load of miles on it.. it could be at least "part" of the problem.. I jiggled mine it started and "Knock on wood" it hasn't done it to me since.. been about three weeks now or so now.. Id like to be able to be positive that its not gonna happen again.. but this is a free solution to try. even if it is a temporary fix. Let me know if you have any success trying it..

  • j_marine 08/12/09 12:05 pm PST


    Hello, I'm Jesse who has a brother-in-law who is a skilled mechanic. I think you are on to something with the driver side door switch. I also have a 2001 2WD Blazer and just recently began experiencing the "Turns over, but no start" problem. Just before it started happening, we were working on the driver side window and briefly messed with the driver side door switch. I was taking the route the others above were taking leading up to the fuel pump, but will definitely "jiggle" the driver side door switch or just flat out replace it. I'll post my findings in the near future.

  • billw67 08/30/09 2:42 pm PST

    I've droped the tank.Have pump out and need to get a couple of jumpers to try the pump out still.
    But now i'm wondering what would happen if I justran a seperate hotwire (relayed and fused ) to the pump.A kind of seperate harness.With spark wouldn't the blazer just run.Maybe like crap but run just the same.
    Oh I've checked the harness at the pump plug in and theres only 1 source of power and it's under12 volts so figure this to be the sending unit supply voltage for the fuel gage.When keys turned it is the only voltage present.
    So my first inclination is the passkey system is shot.I've installed the new ignition switch / harness in the column and tried to reset it thru the turn wait 10 min turn again process to no avail.Truck still turns over but no prime from pump.Think also neeed to recheck the fuel press regulator.Wonder if it's shot if thatwould keep the pump from working.Dang I hate fuel injection and computer controlled cars.Gimme the old days when gas + spark = car runs.

  • keith4566 06/18/11 6:42 pm PST

    my 2001 blazer was doing the same thing so i changed the fuel pump 1 month later it quit running on the side of the road after a tow home and fuel pump exchange (i was told it was a bad pump) i dropped the tank and change it again well now just 3 months later again stranded had to tow home however i can here the pump running but no start.changed the fuel filter can here pump and then it quits tap tank and it comes on and repeated that several times ...no start im stumped

  • big_chris 04/17/12 5:11 pm PST

    i have replace my fuel pump n fuel filter but no gas is gettin up the fuel filter what is wrong with it


Top Fuel System Experts View More

Rank Leader Points
1. MrShift@Edmunds 3860
2. zaken1 3315
3. karjunkie 3165
4. 0patience 690
5. Stever@Edmunds 545
6. docj 525
7. texases 500