Edmunds Answers

Voted Best Answer

  • avatar gmansmom 04/21/10 12:23 pm PST

    I have a 2006 Ford Expedition with the same problem. I took it to my local dealer for diagnostics and it came back Throttle body. They said they couldn't be sure if that is what it really was because of the other codes the ECM was giving..."just continue to drive it and when it happens again, bring it right in." They proceeded to tell my they had a 2006 F150 in for the same problem, lower mileage than mine! I did say to the tech, perhaps you (Ford)should be entertaining a recall. After my husband found these blogs last night, this morning I located Ford Motor Company's website and expressed my concers with them and if it persist, they could possibly be looking at a nationwide class action suit!! I know it's on file with my local dealer that they sent me back into the vehicle knowing the risks. I think we should all email Ford Motor Company, maybe we'll force a recall before there are death associated to this problem.

Answers

  • snowball2 10/08/09 9:44 pm PST

    HAVE YOU HAD THIS THING SCANNED FOR CODES,IF NOT MAYBE YOU SHOULD,THERE MIGHT BE SOMETHING SERIOUS GOING ON

  • jerseygiant 10/08/09 10:10 pm PST

    Have not had it scanned. Each time it happened, I was on the road and just pulled over, shut the engine off and re-started it. Runs fine. I will check with the local Ford dealer to see if this is something they have seen before.

  • snowball2 10/08/09 10:13 pm PST

    THANKS FOR THE UPDATE

  • mbangs 10/15/09 8:54 am PST

    My Friend,
    I just had the same problem with my 2006 F150 FX4 (5.4L), its at the dealer being fixed as we speak. Let me guess, about 60,000 miles on it when it started, correct? What you have encountered is a "Malfunctioning Throttle Body." This is a VERY serious problem, and a pretty expensive problem to fix, its costing me in the range of $550.00 to fix. It's funny though, when I talked to the dealer yesterday they told me they would have it fixed by morning. My question to them was, Why do you have throttle body's in stock for a 2006 F150? These just aren't suppose to just go!!! My truck stalled out on a highway do 65 mph!!! I lost not only my engine but my steering, and my brakes too!! I feel comfortable saying that I have NEVER seen a throttle body fail at 60,000 miles even 150,000 miles. Thats because it is a Life Threatning problem, pretty sad construction on Ford's part and I will be contacting Ford about this issue and I'm going to try to get a refund. We are not the first ones who have had this problem, I talked to another dealer yesterday and thay just had another 2006 F150 5.4L in the shop with the same problem, so this is getting very common. If I can get a hold of someone at Ford I will post the number and contact so that we can get this to be recall. I would think that Ford would want to fix this problem just based on reputation purposes. I will keep you all Posted.

  • snowball2 10/17/09 5:41 pm PST

    I WORKED AT A FORD DEALER FOR AWHILE AND ON AVERAGE THERE WERE 2 -3 AWEEK BEING CHANGED ON THIS ENGINE,ALSO IN THE EXPEDITION

  • jerseygiant 10/17/09 6:19 pm PST

    Thanks for the great info guys. My engine went into the fail safe mode again yesterday. I was able to get some codes which were all related to The TAC system???? Not sure what that is? I am going to see my Ford dealer on Monday and see if I can find out what is going on.

  • snowball2 10/17/09 7:55 pm PST

    NO PROBLEM ANYTIME

  • slz1 01/25/10 12:07 am PST

    hey mbangs, whatever happened with your truck? i drive a 2005 f150, almost at 56000 miles and the other day i went into engine fail safe mode. do you still have your truck?

  • gmansmom 04/21/10 12:23 pm PST

    I have a 2006 Ford Expedition with the same problem. I took it to my local dealer for diagnostics and it came back Throttle body. They said they couldn't be sure if that is what it really was because of the other codes the ECM was giving..."just continue to drive it and when it happens again, bring it right in." They proceeded to tell my they had a 2006 F150 in for the same problem, lower mileage than mine! I did say to the tech, perhaps you (Ford)should be entertaining a recall. After my husband found these blogs last night, this morning I located Ford Motor Company's website and expressed my concers with them and if it persist, they could possibly be looking at a nationwide class action suit!! I know it's on file with my local dealer that they sent me back into the vehicle knowing the risks. I think we should all email Ford Motor Company, maybe we'll force a recall before there are death associated to this problem.

  • senorfrogs36 05/13/10 6:50 pm PST

    Thanks to all who have posted to this. My truck has 84,000 miles on it F150 2005 lariat 5.4l supercrew. Just drove back from a 200 mile trip and next day drove 3 miles to the bank. Came out to start it and it wouldn't start, i tried again and a third time and BAM there was "engine fail safe mode". Called Ford service right away! They were like don't move it, don't drive it, it has to be towed in. So i got it towed and they call and tell me it's the accelerator throttle. Okay I ask is it covered under my 6yr 100k Full coverage plan. They call back and say yes. So like they said it will be a day for it and the next thing I know it they are calling me back to tell me the rear bearings are also bad and they need changed too because there is a howl sound. I told them I have been asking you about that for over 2 plus years and you said you couldn't hear anything, but today they did. So I told them as long as it is covered and my ded is $50.00 change it. Well It has been 4 days plus and I still don't have my truck back.

  • wants2no 02/10/11 7:21 pm PST

    I own a Ford F-150, 5.4L engien, 60,600 miles, and I experienced this problem 3 days ago on my way to work. Suddenly, all of my vehicle's power was gone. I pulled off to the side of the road, turned the truck off, then restarted and it was fine. I took the truck to the Ford dealership today, they put it on a diagnostics machine, and I was told that it NEEDS "TB ASSY"? COST OF REPAIR: around $1000.00?

    FEB. 10, 2011

  • timmy072568 05/01/13 5:09 pm PST

    Yes Im having this problem today, it started on the interstate after changing spark splugs, which gave me hell, so now after it read fail safe and wouldnt go in all the traffic I put it in nuetral and cut it off and restarted it and within 40 min driving home it did it again for a total of 7 times! Now its reading O/D off and transmission malfunction and wont shift out of 1st gear! its an '05 5.4l 4x4, Im too broke to bring it to the dealership, checked all the fuses, gear oil, trans fluid, oil, changed water and coolant too! still wont run right now, Im pissed!!!!!!

ADVERTISEMENT

Top Engine Indicator Lights Experts View More

Rank Leader Points
1. karjunkie 3450
2. MrShift@Edmunds 3235
3. zaken1 1410
4. 0patience 925
5. Stever@Edmunds 535
6. docj 470
7. tony78 395
ADVERTISEMENT