Edmunds Answers

Voted Best Answer

  • avatar zaken1 10/04/08 8:17 pm PST

    There may ba a vacuum hose that was disconnected or is leaking. It also might be caused if the EGR valve is clogged or disconnected. It also could be caused by a bad or disconnected exhaust oxygen sensor. If it is not any of those things, I would either try replacing the spark plugs, or take it to an Auto Zone store; so they can do a free scan to identify the trouble code that is triggering the light. That code will only stay in the computer's memory if the battery is not disconnected before the scan is done.

    I hope this helps!!!
    Joel

Answers

  • ray80 10/04/08 8:14 pm PST

    One of the most common reasons for service emgine soon light is problem with gas cap. Either loose/misaligned/leaky seal. If you have it scanned somewhere at no charge (like auto-zone) it would come back with code that indicates something wrong with evap system.

  • zaken1 10/04/08 8:17 pm PST

    There may ba a vacuum hose that was disconnected or is leaking. It also might be caused if the EGR valve is clogged or disconnected. It also could be caused by a bad or disconnected exhaust oxygen sensor. If it is not any of those things, I would either try replacing the spark plugs, or take it to an Auto Zone store; so they can do a free scan to identify the trouble code that is triggering the light. That code will only stay in the computer's memory if the battery is not disconnected before the scan is done.

    I hope this helps!!!
    Joel

  • petharia 10/04/08 8:24 pm PST

    thank you sooooo much. I'll look into immediately.

ADVERTISEMENT

Top Engine Indicator Lights Experts View More

Rank Leader Points
1. karjunkie 3450
2. MrShift@Edmunds 3235
3. zaken1 1410
4. 0patience 925
5. Stever@Edmunds 535
6. docj 470
7. tony78 395
ADVERTISEMENT