Edmunds Answers

Voted Best Answer

  • avatar karjunkie 04/12/09 8:34 am PST

    Stabilitrak on your truck is ALWAYS ON unless you do one of two things:

    1. Hold the button on the dash next to your 4x4 controls down for about 5 seconds. This will turn off Stabilitrak and it will stay off until you turn the engine off and re-start.

    2. Go to 4x4 Low, in this case the ECM (or another computer) turns Stabilitrak off until you shift out of 4x4 Low. (4x4 Low on some GM trucks also disconnects the odometer).

    If you cannot disable the system, I suspect the wheel sensors are at fault. The only way to know for sure would be to go to your local auto parts store and get a scan of the OBDII for fault codes. Most stores will do it for free. Once you have the codes, come back and we'll take it from there.

Answers

  • karjunkie 04/12/09 8:34 am PST

    Stabilitrak on your truck is ALWAYS ON unless you do one of two things:

    1. Hold the button on the dash next to your 4x4 controls down for about 5 seconds. This will turn off Stabilitrak and it will stay off until you turn the engine off and re-start.

    2. Go to 4x4 Low, in this case the ECM (or another computer) turns Stabilitrak off until you shift out of 4x4 Low. (4x4 Low on some GM trucks also disconnects the odometer).

    If you cannot disable the system, I suspect the wheel sensors are at fault. The only way to know for sure would be to go to your local auto parts store and get a scan of the OBDII for fault codes. Most stores will do it for free. Once you have the codes, come back and we'll take it from there.

  • tylernky 06/08/11 11:58 am PST

    Started yesterday afternoon on my way to an emergency farm visit (I use the Suburban for my VET practice.).Lights indicating Stabilitrak and traction controls are now off. Then they go out, then back on four times will driving down highway at approx: 55 MPH. Then it stated to service, which would go on and off. Then finally all off and everything was fine by the time I made it to the farm.
    2 hours later, with a very ill animal in back that needed emergency surgery, the same happened again on way to office an hour away. Will lights were blinking on and off , the truck became sluggish and then the steering locked up and then released , after that I tried to pull over and the brakes failed for about 15 seconds, then started working and the truck stalled and would not restart. Thanks to several people, they helped me push the truck off road. Meanwhile having an assistant rush to come and get me and the dying animal. After thirty minutes of trying to keep the animal alive: I tried to restart the truck and it would turn over and would continue trying to crank itself for a solid minute with out me turning the key. after three attempts, it started and no lights and ran great: But, with all the loss time, by the time I made it to the clinic and prepped for surgery the animal died. That 45 minutes of truck trouble has caused me to lose a clients animal , that I could have saved.
    This morning, the truck started with no problem. Then at clinic, I go out to start and it did the continual starting sound for about 45 seconds and then it started, but, when drove down the road, between first and second gear a loud boom and jerk and the gauges went haywire and the stereo went to full blast and the brakes quit. This is obvious a very dangerous occurrence that could be deadly.
    After searching all the forums etc, this same exact problem is happening to many 07 and 08 tahoes, yukons, denalis, suburbans,silverados, cadialliac xts and envoys, But, to no avail: the solutions that seem to be a multitude of try and see attempts with great costs to the owner that does not seem to work. I do not want to go thru weeks and weeks of attempts of replacing this and that in which does not fix the problem. Also, it is troubling that with hundreds affected, Gm nor the dealers have a solution. This to me is a potential life threatening defect if steering or brakes fail to work properly, especially if it happens at higher speeds as it did with me.
    Is the Body Modular sensor truly the culprit? Has anyone really gotten the problem fixed? I want to be able to take it in, but, want to have the solution or the recommendation for the repair center to follow. After talking to three service center associates at three different dealers, all three said they have heard of the problem many times, but have no idea how to fix it...Really!? If lives are lost due to the dangers this proposes, I am afraid it will resemble the Toyota Brake fiasco.
    How many vehicles does it take with the same exact problem and dangers before a recall is suggested?
    Thank you all and I love Chevrolet, but, this needs to be addressed.
    If anyone has had a successful repair, please let me know what you had done. thanks all!!

  • just4tahoe 06/24/11 11:34 am PST

    It just started last night, stability/traction light is turning off and on.
    No big problems yet but im definately worried with all the problems these vehicles seem to be having.

    At this point my only suggestion is to go to www.safercar.gov
    I know this website might be your best best.

    Good luck and God bless

  • cts4 05/10/12 3:39 pm PST

    This started happening to me after my tire blew. at 35 in the city i could hear the stabilitrak turn on and my ride would get uncomfortable and at 55 same thing happend in the highway. It is annoying and although i am good with cars i have not found a permanent soloution and my dealer couldnt find the problem either. I have taken the stabilitrak fuse out of the car and my ride is back to normal but my TC and ABS and Brake lights are constantly on which is annoying. I would like to find a fix before winter because it would be helpful to have those systems operational when the PA snow comes down. So if your having these problems the fuse is a quick and cheap temporary fix.

  • nwesley 12/29/12 12:20 am PST

    Second time I had this problem. Drining at about 40 miles/hr. and car accelator barely works. Reduced Engine Power shows as well as Stability trak Off. My compressor does not work and I starting to believe this is the issue. To the dealer.

  • 94bagger 02/20/13 7:08 am PST

    I have a 2008 chevy tahoe and all the above were happening to me. Mine was a very simple fix. Mine was a bad 15A fuse located under the hood in the fuse box. Labeled TCM

ADVERTISEMENT

Top Chevrolet Tahoe Experts View More

Rank Leader Points
1. MrShift@Edmunds 460
2. karjunkie 455
3. zaken1 270
4. 0patience 85
5. morin2 80
6. texases 75
7. tony78 65
ADVERTISEMENT