Edmunds Answers

Voted Best Answer

  • avatar 0patience 02/02/08 2:47 pm PST

    How long you been going to this mechanic?

    Does he have any diagnostic information?

    Code 21 O2S stays centered Neither rich nor lean condition is detected from the oxygen sensor input.
    or
    O2S shorted high Oxygen sensor input voltage maintained above normal operating range.

    SET CONDITION
    The oxygen sensor signal voltage is 0.5 volts for 1.5 minutes.

    PROBABLE CAUSES
    Sensor output wire open
    Oxygen sensor failure

Answers

  • 0patience 01/31/08 11:55 pm PST

    First thing, what were the codes?
    Need the exact numbers. Post back with the numbers, hit submit answer on this thread.
    Then we will try and help you figure out where to start looking.

  • tonye 02/01/08 11:13 pm PST


    Hey thanks for the fast reply.
    Mechanics tell me the check engine was due to a code 21 - lean run. They dumped some fuel injector cleaner in the gas tank.

    Do you think we have something else that might be causing this?

    Tony

  • 0patience 02/02/08 2:47 pm PST

    How long you been going to this mechanic?

    Does he have any diagnostic information?

    Code 21 O2S stays centered Neither rich nor lean condition is detected from the oxygen sensor input.
    or
    O2S shorted high Oxygen sensor input voltage maintained above normal operating range.

    SET CONDITION
    The oxygen sensor signal voltage is 0.5 volts for 1.5 minutes.

    PROBABLE CAUSES
    Sensor output wire open
    Oxygen sensor failure

  • tonye 02/02/08 4:31 pm PST

    Interesting.. We'll bring that up with the mechanic if the check engine light returns.

    Thanks again for the prompt and quality response!

    Tony

  • tonye 02/03/08 10:52 pm PST

    Well.. no check engine light problems...just that the engine stopped then started and repeated several times. Had just made a short trip across town about 20 freeway minutes.Parked for about an hour then we started it up and within minutes the engine dies, no check engine light going 5-10mph. This repeated for several minutes until we returned back to original starting point. The last cycle, the engine was running rough and seemed on the verge of a backfire. An hour later it was ok and made the 20 minute trip back with a single failure. Now I'm wondering if this has become a fuel pump or injector problem. The fuel filter was replaced last year.

  • szeliga 03/13/08 9:36 pm PST

    hi. i would check the computer for code. keyon, keyoff, keyon. I would then check the coolant sensor, located next to the thermostate. It seems your problem started after working on coolant system.

  • jerry_w78130 08/08/08 1:45 am PST

    First of all, I have a 1996 Dodge caravan with the 3.0 liter and while I would be driving it would just die. Everytime it did it I would take it to my mechanic. Finally it did it to him on a test drive. (When it happend we put it into netural and it restarted) He hooked the computer up and the service engine light never came on. The last time it did it, I hooked up a spark tester and found that it was not firing the plugs. Bought a new Coil and never had a problem since.

  • waggawee 08/08/08 2:28 am PST

    You said you tapped the ecm and the check engine light when away for a couple of day? This mean your having loose solder joint, or open joint in the ecm circuit. get a reliable electrican to service the ecm by fixing the open solder or joint in the box and that should fix your problem. Over the years vibration and heating cause the circuit to develope dry solder/joint. so re-soldering it will solve the problem.

    Source: auto electrican

ADVERTISEMENT

Top Engine Indicator Lights Experts View More

Rank Leader Points
1. karjunkie 3450
2. MrShift@Edmunds 3270
3. zaken1 1410
4. 0patience 925
5. Stever@Edmunds 535
6. docj 470
7. tony78 395
ADVERTISEMENT